Comment supprimer l’erreur #DIV/0 ! dans Microsoft Excel ?

Cet article traite de l’erreur #DIV/0 ! dans Microsoft Excel et de la manière de la corriger. L’erreur #DIV/0 ! se produit lorsqu’un nombre est divisé par 0 dans Excel. Elle apparaît également lorsqu’une cellule ne contient aucune valeur ou est vide et que vous avez appliqué une formule de division.

Microsoft-Excel-Logo

Il faut avoir en tête qu’en mathématiques, il est impossible de diviser un nombre par 0.

Or dans un tableau Excel, plusieurs cellules d’un enregistrement peuvent contenir la valeur 0. Si vous avez appliqué une formule de division à une colonne entière et qu’un certain nombre doit être automatiquement divisé par 0, vous recevrez cette erreur #DIV/0 ! Cela donne à votre classeur un aspect très désordonné et désorganisé.

Dans cet article nous allons voir les étapes à suivre pour éviter cette erreur dans Excel.

Comment supprimer l’erreur #DIV/0 ! dans Excel ?

Cette erreur peut être corrigée en utilisant la fonction SIERREUR. Voici les étapes exactes pour corriger l’erreur #DIV/0 ! dans Microsoft Excel :

Lancez Excel et ouvrez le classeur dans lequel vous obtenez cette erreur.

Supposons maintenant que vous deviez diviser les valeurs des cellules de la colonne B par les valeurs des cellules de la colonne C et que vous ayez utilisé la formule =B2/C2.

Cliquez simplement sur une cellule qui affiche l’erreur #DIV/0 ! et allez ensuite dans la boîte de fonctions. Vous devez maintenant ajouter la formule suivante :

Si vous voulez renvoyer une valeur vide en cas d’erreur, utilisez =SIERREUR(B2/C2; » »).

Si vous voulez renvoyer un message en cas d’erreur, utilisez =SIERREUR(B2/C2; »message »).

Pour afficher une valeur 0 à la place de l’erreur, utilisez =SIERREUR(B2/C2;0).

Vous pouvez également utiliser une instruction SI comme =SI(C2=0;0;B2/C2) pour obtenir une valeur de retour de 0 dans le cas où C2 contient un zéro et le résultat du calcul dans le cas contraire.

Pour supprimer cette erreur dans une colonne entière, vous devez copier la même formule dans toute la colonne. Pour cela, vous pouvez sélectionner la cellule, placer le curseur en bas à droite de la cellule, puis le maintenir et le faire glisser vers la fin de la colonne. Cette formule sera appliquée à l’ensemble de la colonne et vous ne recevrez pas de #DIV/0 ! dans l’une des cellules de la colonne.

De la même manière, vous pouvez également utiliser la fonction SIERREUR. Cette fonction renvoie essentiellement la valeur VRAI en cas d’erreur et la valeur FAUX en l’absence d’erreur. Pour afficher VRAI en cas d’erreur #DIV/0 !, vous pouvez utiliser la formule =SIERREUR(B2/C2).