Excel : Adressage absolu et adressage relatif

Lors d’une copie de formule, Excel adapte celle ci de façon à ce que les écarts entre les formules et les cellules adressées restent identiques. Si une adresse  de cellule ne doit pas être modifiée lors d’une recopie, il faut la spécifier en absolu avec le signe $ (touche F4).

Publicités

Sur l’exemple ci dessous, nous calculons le total de chiffres d’affaires de différents vendeurs et les pourcentages des chiffres d’affaires de chacun d’eux :
Le pourcentage pour le premier vendeur s’obtient en divisant son chiffre d’affaire par le total des chiffres d’affaires.

  • Ecrire en B7 la formule =SOMME(B2:B6)
  • Ecrire en C2 la formule =B2/$B$7
  • Le signe $ indique à Excel qu’il ne faut pas modifier l’adresse lors d’une recopie.
  • Appuyer sur la touche F4 pour obtenir le signe $ lorsque le curseur se trouve sur la cellule B7.
  • Cliquer sur C2
  • Taper =
  • Cliquer sur B2
  • Taper /
  • Cliquer sur B7
  • Appuyer sur la touche F4 pour obtenir une adresse en absolu.
  • Valider la formule avec la touche Entrée.

1absolu

Adressage semi-absolu

Dans l’exemple ci dessous, la formule du calcul de pourcentage =B3/B$9 référence la cellule B9 en SEMI-ABSOLU (Il n’y a le signe $ que devant la ligne).

B$9 signifie que le numéro de la ligne 9 ne sera pas modifié lors d’une copie de formule. En revanche la colonne (B) sera adaptée lors d’une  copie de formule. Ceci permet de copier le champ des formules de JANVIER (C4.C8) pour le mois de FEVRIER (F4.F8).

Lorsque la formule est écrite avec la souris ou les flèches, une adresse semi-absolue s’obtient en appuyant deux ou trois fois sur la touche F4 au moment ou le curseur est placé sur la cellule.

2semiabsolu

On obtient

3semiabsolu

Autre exemple

Sur cet exemple, nous calculons les prix des produits en Dollar et en Yen et £. La formule en C6 est copiable aussi bien dans la colonne que dans la ligne.

Pour obtenir le semi-absolu sur la colonne, appuyer sur la touche F4 3 fois.

4semiabsolu

Publicités
%d blogueurs aiment cette page :