Vérifier si vos extensions Firefox fonctionneront avec la version 57

Avec la version 57 de Firefox qui va sortir le 14 novembre  2017, les extensions classiques dites « legacy extensions » ne fonctionneront plus avec cette nouvelle mouture du navigateur.

Un nouveau format d'extensions appelé WebExtensions a en effet été développé par Mozilla. Les développeurs ont été encouragés à mettre à jour leurs extensions pour qu'elles soient compatibles avec ce nouveau format

Dès à présent sans installer une version non finalisée encore en développement de Firefox (Firefox Nightly), il est possible de savoir si les extensions que l'on utilise sont compatibles ou pas avec ce nouveau standard. Pour cela, il suffit depuis le menu Outils du navigateur de cliquer sur Modules complémentaires.

Sur la page Gestionnaire de modules complémentaires, les extensions non compatibles avec le format WebExtensions sont clairement indiquées par la mention OBSOLÈTE. Ces extensions ne fonctionneront donc plus à partir de la version 57 de Firefox et seront automatiquement désactivées. Si leurs développeurs les mettent à jour, elles seront alors réactivées dans Firefox.

Celles qui ont été revues et mises à jour sont signalées par une étiquette libellée « Compatible avec Firefox 57 et versions supérieures ».

logo-firefox

Mozilla indique que cette nouvelle technologie d'extensions modernise leur développement tout en renforçant la sécurité du navigateur.

En effet, ces WebExtensions n'autoriseront plus la modification du code informatique de Firefox ce qui entrainait des problèmes d'instabilité et la mise en œuvre d'extensions parfois malveillantes.

En outre, elles sont assez similaires dans leur fonctionnement interne aux extensions développées pour les navigateurs Chrome, Opera et Edge, ce qui devrait faciliter les conversions d'extensions entre les divers navigateurs.

Il semble quand même que de nombreux développeurs, dépités par les choix techniques de Mozilla, n'aient pas fait le travail pour adapter leurs anciennes extensions à ce nouveau standard. Elles vont donc disparaître.

Contrairement à l'ancien format d'extensions, le nouveau standard est moins ouvert et ne permet pas de développer des extensions aussi pointues notamment pour la modification de l'interface utilisateur, ce que regrettent vivement les développeurs.

C'est d'autant plus regrettable que Firefox est en nette perte de vitesse par rapport notamment au rouleau compresseur qu'est Google Chrome. Le nombre de téléchargements est en chute libre.

Ce désamour des utilisateurs a été pointé du doigt par l'ancien directeur technique de Firefox, Andreas Gal, qui explique sur son blog que Firefox risque de disparaître assez rapidement (deux ans) du paysage des navigateurs Web.

Il n'est donc pas du tout certain que le passage à la version 57 de Firefox fasse gagner du terrain au navigateur, bien au contraire, car si leurs extensions préférées ne fonctionnent plus, les utilisateurs se tourneront à coup sûr vers Chrome qui offre une bibliothèque incomparable d'extensions.

La seule solution serait de ne pas faire la mise à jour vers la version 57, mais c'est certainement une fausse bonne idée, du moins sur le long terme.

Publicités

Author: Ballajack

Share This Post On
51 Partages
Tweetez11
Partagez39
+1
Partagez1